Home / Linux / How to install ExpanDrive for Ubuntu, Mint, Debian, CentOS, RHEL Linux

How to install ExpanDrive for Ubuntu, Mint, Debian, CentOS, RHEL Linux

Here we are showing the process to install and configure ExpanDrive on Ubuntu 19.04 along with Redhat or Centos Linux. 

What is ExpanDrive?

Expandrive is an application that allows users to mount the cloud storage drives directly on the Windows, MacOS and Linux just like the local drives under the Expandrive app. It helps to make us hassle free of opening browser and log in to cloud storage for downloading or uploading some file.

The cloud providers it supports are Dropbox, Google Drive, Google Team Drives, Amazon Drive, Box, OneDrive, OneDrive for Business, Sharepoint, OOpenStackSwift, BackBlaze B2, Amazon S3 or your own SFTP, FTP or WebDAV server and SMB/Windows File Sharing.

Installation of ExpanDrive is pretty easy on Windows and MacOS, however, for Ubuntu and RedHat, the company has recently publicized the Linux version of the same software. Here we are showing the installation on Ubuntu and Redhat which will the same for other Linux OS such as Linux Mint, Debian, Elementary OS, Centos, Fedora including older versions of Ubuntu such as 18.04, 17.04, 16.04, 15.04…

Install ExpandDrive for Linux on Ubuntu/Debian/Mint

  1. Login to your Linux Debian based operating system.
  2. Here we are using Ubuntu 19.04 for the Expandrive installation.
  3. Open the browser.
  4. Go to ExpanDrive website. Here is the link for that.
  5. Download Linux ExpandDrive version for your Operating system. For Debian based select ExpanDrive_x.x.x_amd64.deb.
  6. Now open the Command terminal, keyboard shortcut CTRL+ATL+T
  7. Switch to Downloads directory. The command for that
  8. Type: ls to see the files inside the Downloads directory
  9. Now type the below command to install Expandrive Linux version

The output of the command:

[email protected]:~$ cd Downloads/
[email protected]:~/Downloads$ ls
ExpanDrive_7.0.3_amd64.deb  ExpanDrive_7.0.3_amd64.deb.part
[email protected]:~/Downloads$ sudo apt install ./ExpanDrive_7.0.3_amd64.deb 
[sudo] password for h2s: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'expandrive' instead of './ExpanDrive_7.0.3_amd64.deb'
The following packages were automatically installed and are no longer required:
  fonts-liberation2 fonts-opensymbol gir1.2-geocodeglib-1.0
  gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0 gir1.2-gudev-1.0
  gir1.2-udisks-2.0 grilo-plugins-0.3-base gstreamer1.0-gtk3 guile-2.2-libs
  libboost-date-time1.67.0 libboost-filesystem1.67.0 libboost-iostreams1.67.0
  libboost-locale1.67.0 libcdr-0.1-1 libclucene-contribs1v5 libclucene-core1v5
  libcmis-0.5-5v5 libcolamd2 libcurl4 libdazzle-1.0-0 libe-book-0.1-1 libeot0
  libepubgen-0.1-1 libetonyek-0.1-1 libevent-2.1-6 libfreerdp-client2-2
  libfreerdp2-2 libgc1c2 libgee-0.8-2 libgom-1.0-0 libgpgmepp6 libgpod-common
  libgpod4 liblangtag-common liblangtag1 liblirc-client0 liblua5.3-0
  libmediaart-2.0-0 libminiupnpc17 libmspub-0.1-1 libodfgen-0.1-1
  liborcus-0.14-0 libqqwing2v5 libraw19 librevenge-0.0-0 libsgutils2-2
  libsuitesparseconfig5 libvncclient1 libwinpr2-2 libxmlsec1 libxmlsec1-nss
  lp-solve media-player-info python3-mako python3-markupsafe syslinux
  syslinux-common syslinux-legacy usb-creator-common
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  gconf-service gconf-service-backend gconf2 gconf2-common libappindicator1
  libdbusmenu-gtk4 libgail-common libgail18 libgconf-2-4 libgtk2.0-0
  libgtk2.0-bin libgtk2.0-common
Suggested packages:
  gconf-defaults-service indicator-application
The following NEW packages will be installed:
  expandrive gconf-service gconf-service-backend gconf2 gconf2-common
  libappindicator1 libdbusmenu-gtk4 libgail-common libgail18 libgconf-2-4
  libgtk2.0-0 libgtk2.0-bin libgtk2.0-common
0 upgraded, 13 newly installed, 0 to remove and 294 not upgraded.
Need to get 3,031 kB/84.4 MB of archives.
After this operation, 400 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://in.archive.ubuntu.com/ubuntu disco/universe amd64 libdbusmenu-gtk4 amd64 16.04.1+18.10.20180917-0ubuntu1 [27.1 kB]
Get:2 http://in.archive.ubuntu.com/ubuntu disco/main amd64 libgtk2.0-common all 2.24.32-3ubuntu1 [125 kB]
Get:3 http://in.archive.ubuntu.com/ubuntu disco/main amd64 libgtk2.0-0 amd64 2.24.32-3ubuntu1 [1,777 kB]
Get:4 /home/h2s/Downloads/ExpanDrive_7.0.3_amd64.deb expandrive amd64 7.0.3 [81.3 MB]
Get:5 http://in.archive.ubuntu.com/ubuntu disco/universe amd64 libappindicator1 amd64 12.10.1+18.04.20180322.1-0ubuntu2 [22.7 kB]
Get:6 http://in.archive.ubuntu.com/ubuntu disco/universe amd64 gconf2-common all 3.2.6-5ubuntu1 [699 kB]
Get:7 http://in.archive.ubuntu.com/ubuntu disco/universe amd64 libgconf-2-4 amd64 3.2.6-5ubuntu1 [84.6 kB]
Get:8 http://in.archive.ubuntu.com/ubuntu disco/universe amd64 gconf-service-backend amd64 3.2.6-5ubuntu1 [58.0 kB]
Get:9 http://in.archive.ubuntu.com/ubuntu disco/universe amd64 gconf-service amd64 3.2.6-5ubuntu1 [17.7 kB]
Get:10 http://in.archive.ubuntu.com/ubuntu disco/universe amd64 gconf2 amd64 3.2.6-5ubuntu1 [83.3 kB]
Get:11 http://in.archive.ubuntu.com/ubuntu disco/main amd64 libgail18 amd64 2.24.32-3ubuntu1 [14.4 kB]
Get:12 http://in.archive.ubuntu.com/ubuntu disco/main amd64 libgail-common amd64 2.24.32-3ubuntu1 [114 kB]
Get:13 http://in.archive.ubuntu.com/ubuntu disco/main amd64 libgtk2.0-bin amd64 2.24.32-3ubuntu1 [7,740 B]
Fetched 3,031 kB in 15s (197 kB/s)                                             
Selecting previously unselected package libdbusmenu-gtk4:amd64.
(Reading database ... 123503 files and directories currently installed.)
Preparing to unpack .../00-libdbusmenu-gtk4_16.04.1+18.10.20180917-0ubuntu1_amd64.deb ...
Unpacking libdbusmenu-gtk4:amd64 (16.04.1+18.10.20180917-0ubuntu1) ...
Selecting previously unselected package libgtk2.0-common.
Preparing to unpack .../01-libgtk2.0-common_2.24.32-3ubuntu1_all.deb ...
Unpacking libgtk2.0-common (2.24.32-3ubuntu1) ...
Selecting previously unselected package libgtk2.0-0:amd64.
Preparing to unpack .../02-libgtk2.0-0_2.24.32-3ubuntu1_amd64.deb ...
Unpacking libgtk2.0-0:amd64 (2.24.32-3ubuntu1) ...
Selecting previously unselected package libappindicator1.
Preparing to unpack .../03-libappindicator1_12.10.1+18.04.20180322.1-0ubuntu2_amd64.deb ...
Unpacking libappindicator1 (12.10.1+18.04.20180322.1-0ubuntu2) ...
Selecting previously unselected package gconf2-common.
Preparing to unpack .../04-gconf2-common_3.2.6-5ubuntu1_all.deb ...
Unpacking gconf2-common (3.2.6-5ubuntu1) ...
Selecting previously unselected package libgconf-2-4:amd64.
Preparing to unpack .../05-libgconf-2-4_3.2.6-5ubuntu1_amd64.deb ...
Unpacking libgconf-2-4:amd64 (3.2.6-5ubuntu1) ...
Selecting previously unselected package gconf-service-backend.
Preparing to unpack .../06-gconf-service-backend_3.2.6-5ubuntu1_amd64.deb ...
Unpacking gconf-service-backend (3.2.6-5ubuntu1) ...
Selecting previously unselected package gconf-service.
Preparing to unpack .../07-gconf-service_3.2.6-5ubuntu1_amd64.deb ...
Unpacking gconf-service (3.2.6-5ubuntu1) ...
Selecting previously unselected package gconf2.
Preparing to unpack .../08-gconf2_3.2.6-5ubuntu1_amd64.deb ...
Unpacking gconf2 (3.2.6-5ubuntu1) ...
Selecting previously unselected package libgail18:amd64.
Preparing to unpack .../09-libgail18_2.24.32-3ubuntu1_amd64.deb ...
Unpacking libgail18:amd64 (2.24.32-3ubuntu1) ...
Selecting previously unselected package libgail-common:amd64.
Preparing to unpack .../10-libgail-common_2.24.32-3ubuntu1_amd64.deb ...
Unpacking libgail-common:amd64 (2.24.32-3ubuntu1) ...
Selecting previously unselected package libgtk2.0-bin.
Preparing to unpack .../11-libgtk2.0-bin_2.24.32-3ubuntu1_amd64.deb ...
Unpacking libgtk2.0-bin (2.24.32-3ubuntu1) ...
Selecting previously unselected package expandrive.
Preparing to unpack .../12-ExpanDrive_7.0.3_amd64.deb ...
Unpacking expandrive (7.0.3) ...
Setting up gconf2-common (3.2.6-5ubuntu1) ...

Creating config file /etc/gconf/2/path with new version
Setting up libgtk2.0-common (2.24.32-3ubuntu1) ...
Setting up libdbusmenu-gtk4:amd64 (16.04.1+18.10.20180917-0ubuntu1) ...
Setting up libgconf-2-4:amd64 (3.2.6-5ubuntu1) ...
Setting up libgtk2.0-0:amd64 (2.24.32-3ubuntu1) ...
Setting up libappindicator1 (12.10.1+18.04.20180322.1-0ubuntu2) ...
Setting up libgail18:amd64 (2.24.32-3ubuntu1) ...
Setting up libgtk2.0-bin (2.24.32-3ubuntu1) ...
Setting up libgail-common:amd64 (2.24.32-3ubuntu1) ...
Setting up gconf-service-backend (3.2.6-5ubuntu1) ...
Setting up gconf-service (3.2.6-5ubuntu1) ...
Setting up gconf2 (3.2.6-5ubuntu1) ...
Setting up expandrive (7.0.3) ...
Processing triggers for libc-bin (2.29-0ubuntu1) ...
Processing triggers for man-db (2.8.5-2) ...
Processing triggers for desktop-file-utils (0.23-4ubuntu1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.32.0-1ubuntu1) ...
[email protected]:~/Downloads$

Setup Epandrive for Linux

Click on the Expandrive icon to run it.

ExpanDrive for Linux Ubuntu

Enter the name and email address and click on Start free trial.

Expandrive signup

Select the cloud storage service you want to connect with and follow the wizard.

Select the Cloud storage

We have used it connect Google Drive

Save the drive path

For Expandrive installation on Redhat, Centos, Fedora and the other same type of Linux OS, the only difference will be the command to install the software.

That means first download the Expandrive for RHEL from its official website the link for that has been given at the beginning of this article and install it using below command:

 yum localinstall ./ExpanDrive-7.0.3.x86_64.rpm

Other Useful Resources:

 

Loading...

>> Source Link

Check Also

Best Android phones in India

If you’re in the market for the best smartphone in India and not going the …

%d bloggers like this: